Issues reported with outgoing email
Incident Report for Hypernode
Resolved
The issue has been resolved.
Posted Apr 11, 2022 - 15:06 CEST
Investigating
We're getting reports of issues with sending outgoing mail through e-mail applications, and messages that our IP Address is block listed. We're currently investigating this and will provide updates when we have more information.
Posted Apr 11, 2022 - 11:19 CEST
This incident affected: E-mail Platform.