Problems renewing Let's Encrypt certificates

Incident Report for Hypernode

Resolved

This incident has been resolved.
Posted Feb 25, 2020 - 09:00 CET

Monitoring

We have rolled out a fix to our nameservers, and renewing Let's Encrypt certificates is possible once again.
Posted Feb 24, 2020 - 13:47 CET

Update

We have identified the source of the problem in the interaction between the new Remote Validation system implemented by Let's Encrypt, and DNS servers used for domains registered through the byte.nl Service Panel.

We are working on a fix for this in our DNS servers.
Posted Feb 24, 2020 - 13:27 CET

Identified

We have received reports that Let's Encrypt certificates are, in some cases, unable to be renewed. We are currently investigating the source of this disruption.

Customers may receive any of the errors below when trying to renew their certificate:

* DNS problem: query timed out looking up CAA
* During secondary validation: Remote PerformValidation RPC failed
Posted Feb 21, 2020 - 12:00 CET
This incident affected: Third-Party Service Providers.