Degraded performance when applying changes to Hypernodes

Incident Report for Hypernode

Resolved

This incident has been resolved.
Posted Jul 09, 2026 - 12:37 CEST

Update

All systems operational. A synchronization primitive in our automation system got stuck in a dead state. We're implementing monitoring rules to identify similar issues in the future, while we keep monitoring the system for dead locks.
Posted Jul 09, 2026 - 12:36 CEST

Monitoring

A fix has been rolled out and missed changes will now be handled, please keep an eye out on the `hypernode-log` for any missed actions.
Posted Jul 09, 2026 - 11:51 CEST

Investigating

We're currently experiencing some degradation when making changes to Hypernodes (version changes, whitelists, SSH keys). Please contact support for urgent cases. This does not influence general availability for your server or application.
Posted Jul 09, 2026 - 11:40 CEST
This incident affected: Hypernode Platform (Hypernode Toolset / API / Control Panel).